Time zone won't let me access bnz apps

Hi @coronation, not that I’m aware of. @Nick, is this a known issue and if so is there a fix for it? Or will customers needs to contact us directly to solve it?

Hi Lawrence

I have had three customers so far with this issue - yesterdays was a New to Bank - there just wasn’t a response on the Community how that person’s issue was solved which would help with my customers.


I’ll chase Nick up on this for you :slight_smile:

We had a customer with this problem the other day. If its a brand new phone they have to restart it to allow the timezone to kick in properly. This seemed to have worked for their phone. (iPhone)

I am having the same issue on my iphone, timezone issue. I tried restarting couple of times and now I cannot even login.

Hi @Bridgettelahman, @coronation , I am having the timezone issue on my iphone. I tried restarting couple of times and my timezone setting are set to automatic. Let me know if you guys have a fix for this.

Hi, sorry for taking time to respond here. The security we have built into the app has a security token that requires the devices time to be set correctly in the timezone you are in.

So the best scenario is (on iPhone) Settings > General > Set Automatically is on and the Time Zone is set to the correct timezone.

If this is how you have it, then please try reinstalling the app and login again - and for this I am sorry for any inconvenience


Hi @Nick . I’ve tried all of the above (restarted phone, have correct time settings, have reinstalled the app) with no luck. Do you have any other fix??

PS I still get access to my accounts, but the time zone error message pops up and the app then doesn’t remember my details for the next time.


It’s because you are using Apple. You have to do everything “their” way. Even if their way is wrong, or stupid.

No wonder so many people say Apple is rotten to the core. No wonder too that Android is used by far, far more people than Apple. And yes, cost is a factor, but also because you have to do “everything” Apples way.

Hey there, I’m really sorry to hear about the experience you’ve had trying to get the Mobile App sorted. It definitely shouldn’t be this difficult :pensive: I’ve just spoken with our Tech guys who asked if you could send a screenshot of your Date and Time settings. ^Alyssia

I’m great thanks! Yes, let’s get to the bottom of this for you =) I’ll be in touch shortly once I have an update from our Tech guys. ^Alyssia

Hey, I’m finished for the day but I’ve checked in with our Tech guys and they’ve had to escalate this issue higher. They mentioned it would be really good if you can call them on 0800 269 424 so they can walk you through a couple of potential fixes but if not, I’ll be in touch when I have another update. Appreciate your patience. ^Alyssia :slightly_smiling_face:

Hey, I’ve just had an update from our Tech Guys and they mentioned that you’ve been able to get the App sorted? Let us know if you’re still having issues. Fingers crossed you’re not :crossed_fingers: ^Alyssia

All good now thanks :+1:

1 Like

Hi Guys. Can you pleae just post a fix for this or things to try? I’m sure it must affect other people (like me) so it would save a lot of time for people if something is posted. This thread comes up first when you search the issue. Thanks!

Update for people visiting this page. BNZ actually have no fix for this yet. I’ve wasted a couple of hours of my life working that out. PS I am Iphone X and have followed all of the potential fixes above which have not worked. If you are time poor like me I wouldn’t bother ringing BNZ but hopefully something will be posted here in the future. When they get back to me with a fix I will post here anyway.

Any updates on this I just got a iPhone 11 and am having the same issues. Have tried all the above fixes

Has there been any progress on this issue ? I can’t activate on either iPhone 11 or iPad . Tried all proposed fixes with no joy. It has only successfully activated once on my iPhone 6 And that was a year ago.

Any help would be great as this is really frustrating, also what has Timezone got to do with activation of the app shouldn’t it all resolve regardless of what Timezone you are in?

I had the same issue on iPhone 11 pro tried again and again using the 2 step authentication process and net card then. It worked fine on my iPhone 6 and I pad the randomly today it worked and activated fine

Hi BNZers - I fixed the issue in branch by cancelling the Netguard card and ordering a new one (BS 14.16) - restart the app and you will be able to set it up as normal. All the other troubleshooting tips did nothing but this did the trick! If any customers reading this have this issue - just let us know to try this :slight_smile: