CSV Exports with dates jumbled


#1

Hi,
When I export statements in CSV format the dates are not in a usable format. It seems like the date is export in ccdd/mm/yy format (instead of dd/mm/ccyy).
Am I doing something wrong?

Look at these dates;

image

Thanks


#2

Hi LouH

That definitely doesn’t look right. While in Excel, would you be able to select column A entirely and press the shortcut ‘Ctrl + 1’. This should bring up the ‘Format Cells’ window.

In the ‘Date’ category, are you able to make sure that the format ‘14/03/2012’ is selected. Your screenshot almost looks like it’s trying to reverse the date format.

Let me know how you get along.

Regards, Hayden


#3

I eventually found out that it’s because I have custom short date format set for Windows (10).
The standard is “d/MM/yyyy”, but I prefer “yyyy-MM-dd”.
If I reset that format (Control panel, Regional settings, Customise Format, Date “Short Date:” back to standard, it works.

Not sure if it’s a Excel CSV import thing or a BNZ CSV creation thing, but irritating as bugger…