Credit cards page


#1

The credit cards page (https://www.bnz.co.nz/support/credit-cards)) seems to be broken for me in Firefox (Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0) as the dropdown menus aren’t dropping down to reveal more content. They work fine in Chrome and IE11 though. Give Gecko some love? :slight_smile:


#2

Thanks @brad, we’ll take a look.


#3

Hi @brad - we love Firefox (and always test every new feature against it and other modern browsers), but we can’t seem to recreate the issue you’re seeing on any recent version on Firefox on Windows or OSX.
If you’re still seeing an issue it’d be great to see the content of any errors you’re seeing in the console and to hear whether a force-refresh (Ctrl+Shift+R in Windows) fixes it for you?


#4

Hmm, that’s weird! I expected it to be something kinda simple - sorry for the really short bug report :slight_smile:

No change after clearing cache and disabling all my addons. I can’t see anything out of the ordinary in the console output but I did a little digging and that’s led me to assume this might be an issue specific to the combination of Firefox and Windows 10. I can’t reproduce this on the only other PC I have handy at the moment which is a Debian Jessie system with Firefox (Iceweasel) 38.

I had a look in Firefox’s development tools inspector and noticed that there are no event handlers attached to any of the links specifically but there is a ‘tap’ handler attached to the list (nav#support-navigation > ul.supportnav). If I remove the href attributes from the links using the inspector (so that they are not followed), put Firefox in responsive design view (ctrl+shift+M) and then enable simulating touch events, clicking on the links collapses their content. However, when simulating touch events is disabled, clicking on the links does nothing. In both cases, the default action is not prevented (i.e. the link would be resolved if I hadn’t removed the href attributes).

Hopefully that’ll help point you in the right direction? I’m truly sorry if I’ve just caused you to have to go hunting for some Windows 10 virtual machines…


#5

Hi @brad - we’ve managed to recreate this and should have a fix out in the next few weeks. Thanks again for the feedback and the extra info!


#6

Hi again @brad - you may have already noticed it, but this should now be working in Firefox. Let me know if you’re still seeing any weird behaviour!


#7

Awesome @Stuart, nice work team!